Skip directly to content

Help

Contact Us

Please contact us with any questions regarding ClassPoP.

System Requirements

Monitor: Minimum 1024×768 required. Higher resolution is recommended.

Browsers:


Windows:

Firefox 4.0 or later;

Chrome 16.0 or later

Internet Explorer 9 or later;

( Note: please choose the "always show all mixed content" option as described at http://www.mydigitallife.info/how-to-disable-only-secure-content-is-disp... )

Safari 5.0 or later


Macintosh:

Firefox 4.0 or later;

Chrome 16.0 or later


Linux:

Firefox 4.0 or later


JavaScript and Flash: Your browser must have JavaScript enabled, and a Flash plugin installed.

Network Connection:We recommend you have a broadband connection (LAN, DSL, or cable modem) when using Classpop.

Audio Output: Speakers or headphones (necessary if you are using this tool in a computer lab)